Verity Service, Degraded Performance for Europe users

Incident Report for Caseware Cloud

Resolved

This incident has been resolved.
Posted Aug 12, 2026 - 13:18 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 12, 2026 - 13:08 UTC

Identified

We are experiencing a Degraded Performance impacting Verity Service in Europe region(s). Our teams are actively investigating the issue, identifying the root cause, and implementing the necessary corrective actions. An update will be provided within the hour.
Posted Aug 12, 2026 - 12:55 UTC

Investigating

We are experiencing a Degraded Performance impacting Verity Service in Europe region(s). Our teams are actively investigating the issue, identifying the root cause, and implementing the necessary corrective actions. An update will be provided within the hour.
Posted Aug 12, 2026 - 12:42 UTC
This incident affected: Europe (EU) (Data Analytics Platform).