Caseware Cloud Service Performance Degradation for Users in United States
Incident Report for Caseware Cloud
Resolved
The Caseware Cloud Service have been restored to normal operation in the United States region.
We thank you for your patience and understanding during the service disruption.
Posted May 02, 2024 - 19:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 02, 2024 - 18:55 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 02, 2024 - 18:33 UTC
Update
We are continuing to investigate this issue.
Posted May 02, 2024 - 18:31 UTC
Investigating
We are currently experiencing performance degradation of our Caseware Cloud Service in the United States region. We are working to identify the root cause and determine the necessary corrective actions.
An update will be provided within the hour.
Posted May 02, 2024 - 18:30 UTC
This incident affected: United States (US) (Caseware Cloud Service).